Jump to content
VictorUs

Программирование джойстиков от VKB

Recommended Posts

10 минут назад, Magenta сказал:

Ребята, что то я затупил ...

Датчик VSS - >  5  RJ-45

Датчик GND ->  6,8,4 RJ-45

Датчик Sig   ->  3 RJ-45

 

Как теперь сделать, что бы контроллер увидел эту ось ?

 

См. настройки ось № 7, ну и D-Mars нужно записать.

Share this post


Link to post
Share on other sites
50 минут назад, -DED-Ron сказал:

потом проверить связь с датчиком в Test-Misc - зеленая стрелка

 

Но даже если всё сделано правильно - Марсы из ранних рулей могут не завестись на нынешних таймингах опроса.

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
8 часов назад, huligan сказал:

для педалей T-Rudder MkIV какая прошивка и какой конфигуратор нужен?

Ээээ...кхы-кхы:blush:

Share this post


Link to post
Share on other sites

для педалей - практически любые :)

  • Haha 1

Share this post


Link to post
Share on other sites

 

Блин, что то я наконфигурил, что у меня рычаг Break  перестал реагировать, что я тут напутал 

 

ЗЫ. Сбросил в дефаулт, вроде заработал рычаг

 

 

Скрытый текст


1.thumb.jpg.860f25c04e4b580c3583d005795ea7f7.jpg

2.jpg

 

 

Edited by Magenta

Share this post


Link to post
Share on other sites

Все правильно. Это не будет внешнее устройство, будет своя родная ось. Внешним устройством будет ручка. Кстати, а как она будет подключаться? Если нет штатной базы.

Своя механика?

Share this post


Link to post
Share on other sites

Да, механика от MSFFB2 , датчик у меня так и не завелся, в Test Misc 7 ось горит зеленый огонек, но плавного движения нет, так какие то рывки и самопроизвольный дрейф, видимо датчик от геметриксовского руля несколько отличается от современных  D-Mars-ов ...

 

Буду искать датчики посвежее :)

 

Скрытый текст


DSC_6968.thumb.JPG.a6aa1ed28394cbe9272ae29c8a93121d.JPG

 

 

Share this post


Link to post
Share on other sites
10 часов назад, Magenta сказал:

 

Блин, что то я наконфигурил, что у меня рычаг Break  перестал реагировать, что я тут напутал 

 

ЗЫ. Сбросил в дефаулт, вроде заработал рычаг

 

 

  Скрыть содержимое

 

 

 

 

Оси 3 и 4 (хатка) должны быть не 6 и 7, а 5 и 6. Седьмая как раз закреплена за педалями, D-Mars.

Може быть поэтому?

 

  • Upvote 1

Share this post


Link to post
Share on other sites

992355887_Trimmermode.thumb.jpg.6ad16c0a3aaeedd1453b4f624a03c872.jpg

 

1-Standard / 2-Modified

------------------------------------------

 

2 часа назад, Magenta сказал:

Test Misc 7 ось горит зеленый огонек, но плавного движения нет, так какие то рывки и самопроизвольный дрейф

 

Уровень ошибок какой при этом? Стоит, растёт, в максимале?

Edited by Alex_Oz
  • Like 1

Share this post


Link to post
Share on other sites
40 минут назад, Alex_Oz сказал:

Уровень ошибок какой при этом? Стоит, растёт, в максимале?

А как его посмотреть ? полоска которая перед зеленым огоньком пустая (чёрная) , на перемещение оси не реагирует,, вечером сниму скриншоты покажу ...

Share this post


Link to post
Share on other sites

Забыл скриншот, но  датчик D-Mars если подключен, то  после зеленого квадратика в миск тесте, цифра 0 (при этом в тесте движения так же реагирует рывком или стоит на месте), при этом если  подключить его к родному контроллеру руля, то всё нормально , если датчик отключаю, то квадратик становиться красным и после него цифра 250 ...

 

Я тут подумал, что контроллер руля вроде были на на atmega , и соответственно питание на датчик шло 5 в, а BlackBox на STM и питание там 3.3в, может датчику просто напруги не хватает ? Может там можно какой резистор перепаять и заработает ? Или всё же надо тот хитрый затерты чип перешивать ?

 

Edited by Magenta

Share this post


Link to post
Share on other sites

Они и там на 3вольтах работали. Странно вообще. Ошибки должны были бы расти - если бы марсы не вытягивали. Пока ситуация непонятная.

Edited by Alex_Oz

Share this post


Link to post
Share on other sites

Вот запилил видео, может поможет определить где я туплю :)

 

 

 

Share this post


Link to post
Share on other sites

Момент не совсем понятный когда на 7-ю ось мапится кроме марса еще из ручки Axis#6. Формально мешать не должно, но мало ли. Для проверки постаить NONE.

 

PS

просьба видео прятать под спойлер, равно как скриншоты (или зумить)

Edited by Alex_Oz

Share this post


Link to post
Share on other sites

Доступна версия v1_96_5 NG для гладиатора и ганфайтера MCG PRO.

Просьба всем заинтересованным принять участие в тесте.

На данном этапе интересует по большей части работа со штатными функциями.

По нештатным и особенно нововведениям (там еще поле непаханное) - информация также приветствуется и в своё время пригодится.

  • Like 3

Share this post


Link to post
Share on other sites

А потому что он не там.

  • Thanks 1

Share this post


Link to post
Share on other sites

Вот это - кто?

image.png.6689b17960f94b73f2b8ff827882094f.png

 

И в перспективе при добавлении virtual layer джамперы останутся на добрую память об эволюции.

Хотя в особо замороченных случаях возможно пригодятся. Для поклонников олдскул :)

Edited by Alex_Oz

Share this post


Link to post
Share on other sites

А я-то, как честный человек, JMP искал))) 

Thanx!

 

Share this post


Link to post
Share on other sites

Так никто не обещал что будет легко :)

  • Haha 1

Share this post


Link to post
Share on other sites

Не уверен,что пишу в нужную тему,но решусь спросить здесь.

 Играя в БзС заметил,что уж очень чувствительно начал реагировать самолёт на движения РУСа (на этом джойстике играю впервые до этого был Х-52 Про),посмотрев на рули,увидел,что при отклонение ручки примерно % на 30,рули становятся в крайнее положение,то есть очень маленький диапазон РУСа по отношению ко всем рулям(крена,рысканья и тангажа).Поигрался с настройками в игре,положительного результата не получил. Открыл джой тестер и увидел,что происходит тоже самое,то есть не много отклоняя ручку,линия оси уже убегает в крайнее положение.

Так вот вопрос, это надо было произвести калибровку или это надо как то настраивать ?

 П.С. Скачал программу Configurator NJoy32 но пока в ней не разобрался, да и с английским у меня беда, так вот,есть ли руссификатор на данную программу, думаю на родном языке она будет не много легче восприниматься?

Share this post


Link to post
Share on other sites

Нужно повторно откалибровать.

Русификатор имеется на паравозной.

Рекомендуется ознакомиться с Руководством пользователя.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Добавлена еще одна функция виртуальных тормозов, управляемых кнопкой - BrakeV1

BrakeV1.thumb.jpg.ea3c05d2490ceebf434c2feb3957f0ad.jpg

По настройкам идентична Brake

Принцип работы :

Пока не нажата кнопка, управляющая осью автотриммера (4) - работают дифференциальные тормоза в зависимости от направления (один полностью расторможен всегда)

Порог начала работы оси тормоза от центра задаётся %

 

при нажатии кнопки тормоза (автотриммера) работают обе оси тормозов.

Но если дана педаль, то сначала пустая ось догонит рабочую и далее -  синхронно будут увеличиваться.

При отпускании кнопки обе оси уменьшаются, нерабочая - до нуля, рабочая - до значения, заданного педалькой.

 

Прошивка отдельно в корне (_BlackBox_TRudder_v1_96_7.vkb)

VKBDevCfg-C_v0.89.44

 

Edited by Alex_Oz
  • Like 3
  • Thanks 4

Share this post


Link to post
Share on other sites

Прошил - но BrakeV1 не появился в выпадающем меню.

92222.JPG

Все заработало - вечером буду тестировать в дкс, спасибо!!

Share this post


Link to post
Share on other sites

не удержался и проверил взлет - это просто ШЕДЕВР!!!! ОГРОМНОЕ СПАСИБО!!!

Edited by VogelS
  • Like 1

Share this post


Link to post
Share on other sites
14 часов назад, Vumpel18 сказал:

Нужно повторно откалибровать.

Русификатор имеется на паравозной.

Рекомендуется ознакомиться с Руководством пользователя.

А как русифицировать то? Всё время на инглише у меня.🙄

Share this post


Link to post
Share on other sites

image.thumb.png.479f3585cd620c2f1d863b7a44ef873c.png

 

6 часов назад, VogelS сказал:

не удержался и проверил взлет - это просто ШЕДЕВР!!!! ОГРОМНОЕ СПАСИБО!!! 

 

Взаимно!

  • Like 1

Share this post


Link to post
Share on other sites
16 часов назад, Vumpel18 сказал:

Нужно повторно откалибровать.

Русификатор имеется на паравозной.

Рекомендуется ознакомиться с Руководством пользователя.

Спасибо,буду пробовать.

"Паравозная" это где ?

Сейчас штудирую мануал "Конфигуратор контроллера NJoy32" в 130 листов.

Share this post


Link to post
Share on other sites
1 час назад, mihey13 сказал:

Спасибо,буду пробовать.

"Паравозная" это где ?

Сейчас штудирую мануал "Конфигуратор контроллера NJoy32" в 130 листов.

http://forum.vkb-sim.pro/viewtopic.php?f=15&t=908

  • Thanks 1
  • Haha 1

Share this post


Link to post
Share on other sites

Подскажите, а что там с ручкой для F14 Tomcat от Heatblur Simulations?

И еще вопрос, а когда будут доступны комплекты апгрейда для MCG Pro? (сменные кнопки, хатки на манер Космосимы)

Share this post


Link to post
Share on other sites

Ребят,спасибо за помощь и предоставленную информацию. 

 РУС успешно откалибровал,теперь работает как надо,установил руссификатор (кстати не очень то он и помог :unsure::)),добавил все недостающие функции в zconfig.ini, короче потихоньку осваиваю .

Теперь для полного счастья хочу откалибровать педали T-Rudder MkIV, а то у них такая же проблема как у РУСа до калибровки (мой пост выше). Как до этого летал,ума не приложу :lol:.

 Как я понял,для этого нужна программа " Т-Link",скачал её там же где и конфигуратор ( https://mega.nz/#F!5kUS1SBJ!0a1ukKaeLeDXWIe3OPugoA ),но при запуске она почему то педали не видит,моргает красным,что "Disconnected".

Подскажите в чём причина или есть возможность в NJoe32 их откалибровать ?

 

 

  • Sad 1

Share this post


Link to post
Share on other sites

 MklV калибровать в конфигураторе, соответственно выбрав педали.

Предварительно обновите прошивку до аналогичной версии ручки MCG.

  • Thanks 1
  • Sad 1

Share this post


Link to post
Share on other sites
3 минуты назад, Vumpel18 сказал:

 MklV калибровать в конфигураторе, соответственно выбрав педали.

Предварительно обновите прошивку до аналогичной версии ручки MCG.

То есть надо прошить педали до версии 1.95 и они не отображаются в конфигураторе потому,что не та прошивка?

Если не трудно,дайте ссылку на прошивку и инструкцию по её установке. 

П.С.    Для ясности выложил данные из вкладки "Инфо" в конфигураторе:  

HID-совместимый игровой контроллер
Product Name:  VKB-Sim Gunfighter Modern Combat Pro 
PRO version 
T-Link  supported
Firmware version:  v1.95B
Rudder On
 
HID-совместимый игровой контроллер
Product Name:  VKB-Sim Gunfighter Modern Combat Pro 
PRO version 
T-Link  supported
Firmware version:  v1.95B
Rudder On

 

Share this post


Link to post
Share on other sites

T link - он для настройки тормозов.

Share this post


Link to post
Share on other sites

Не нужно заводить коллегу в заблуждение.

Речь идёт о калибровке, а не настройке топтунов.

 

Edited by Vumpel18

Share this post


Link to post
Share on other sites
18 часов назад, VogelS сказал:

Прошил - но BrakeV1 не появился в выпадающем меню.

 

В 13.02.2019 в 01:23, Alex_Oz сказал:

VKBDevCfg-C_v0.89.44

583501338_.thumb.jpg.8b864f9c1d583c4a70c974e16d000c91.jpg

Edited by huligan

Share this post


Link to post
Share on other sites

Опробовал прошивку 1.96.7, проблема SPI-2 осталась, откатился обратно на 1.95.А - где всё нормально. 

 

проблема была выявлена, и описана выше.

 

В 31.01.2019 в 03:41, DuHast сказал:

Долго тыкался с переборкой всех дивайсов, кучу раз прошивал. В итоге вычислил что проблема зарыта в настройках кнопок. Скидываю джой на дефолтные настройки, после можно загрузить всё из профиля кроме кнопок. Всё работает нормально. Но как только изменяешь настройки кнопок 5 и 6 регистра, которые подключены к  SPI-2 порта BUS, на любую функцию отличную от простого нажатия появляются фантомные срабатывания других кнопок, и кнопки работают с мерцанием. Для нормальной работы необходимо назначить на этих регистрах только кнопки или тумблера. Это же  железо пока было Коброй Z работало нормально.

 

Аналогичная проблема у  -DED-Ron

В 01.02.2019 в 07:47, -DED-Ron сказал:

 

У меня 2х-этажный и плата расширения подключена к SPI1и все кнопки там, второй только для Тх1, Тх3 нужен. На нем больше ничего нет. И такие же фантомные срабатывания. Причем на определенных тумблерах и энкодере (одном из 3). Попробуй откатиться не выше 195.В - никаких ложных срабатываний, проверено на 100%.

Стоит ли ждать в ближайшем будущем решения этого вопроса?

Share this post


Link to post
Share on other sites

Не стоит. Это устаревшие функции. Возможности собирать и проверять всевозможные конфигурации - напрочь отсутствует. Кроме того, ни разу на форумах не встречал упоминаний об используемости столь широкого функционала. Особенно когда требуется поддержка коммьюнити - это самое коммьюнити просто отсутствует.

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...