Jump to content
72AG_Crusader

Проблема с ThrottleBox (?)

Recommended Posts

У меня давно возникла описанная ниже проблема. Сейчас удалось её в некоторой степени "изловить".

 

Периодически отключается и подключается ThrottleBox (с соответствующим системным звуком в Windows). Раньше это происходило нечасто и я не мог отловить, когда это происходит. Сейчас обратил внимание, что на боксе загорается и гаснет индикатор SYS. Это соответствует "пропаданию" из списка игровых устройств(контроллеров) в Windows.

К боксу подключены только T-Rudder педали.

Провода 100% рабочие. Оба провода. Меняны, переменяны, перепроверены - проблема от этого не изменяет своё поведение и, соответственно, остаётся.

 

Можете что-то порекомендовать, подсказать?

Share this post


Link to post
Share on other sites

2 варианта на вскидку: питание и разъемы USB...

Share this post


Link to post
Share on other sites

Это Вин 8 отключает контроллер. Когда с датчиков идет стабильный неизменяемый сигнал, контроллер перестает слать пакеты. Оптимизация, чтоб зря по УСБ шине не гонять данные.

Оптимизация вышла боком в Вин8. Уши торчат от "планшетной" сущности винды. Винда видит, что контроллер перестает слать данные и отключает его. Экономия энергии. А контроллер видит, что его отключили и включается снова.

Мы готовим прошивку для совместимости с Вин8. Подождите пожалуйста, стабильный релиз выложим на наш фтп.

З.Ы. Конечно еще может быть проблема плохого контакта в miniUSB коннекторе. Но моя "чуйка" за первый вариант.

  • Upvote 1

Share this post


Link to post
Share on other sites

А запрет отключения питания в диспетчере устройств в свойствах usb не поможет в таком случае?post-275-0-37541000-1443698189_thumb.png

Edited by ANV

Share this post


Link to post
Share on other sites

У меня не помогло. Тем более, если меняется усб порт - надо опять лезть в настройки. Искать к какому порту подключено.. Долго, геморно, гадко (когда в комп включено несколько игровых устройств, которые еще и составные).

Share this post


Link to post
Share on other sites

Это Вин 8 отключает контроллер. Когда с датчиков идет стабильный неизменяемый сигнал, контроллер перестает слать пакеты. Оптимизация, чтоб зря по УСБ шине не гонять данные.

Оптимизация вышла боком в Вин8. Уши торчат от "планшетной" сущности винды. Винда видит, что контроллер перестает слать данные и отключает его. Экономия энергии. А контроллер видит, что его отключили и включается снова.

Мы готовим прошивку для совместимости с Вин8. Подождите пожалуйста, стабильный релиз выложим на наш фтп.

З.Ы. Конечно еще может быть проблема плохого контакта в miniUSB коннекторе. Но моя "чуйка" за первый вариант.

Большое спасибо за разъяснения. Будем ждать.

Share this post


Link to post
Share on other sites

Когда с сайтековским квадрантом возникла похожая проблема (через некоторое время простоя отключался, при этом гас светодиод на нём, что раздражало), поснимал галки экономии энергии в свойствах всех устройств, связанных с usb. Ну и режим энергосбережения установил в высокую производительность. В случае с квадрантом помогло.

  • Upvote 1

Share this post


Link to post
Share on other sites

Когда с сайтековским квадрантом возникла похожая проблема (через некоторое время простоя отключался, при этом гас светодиод на нём, что раздражало), поснимал галки экономии энергии в свойствах всех устройств, связанных с usb. Ну и режим энергосбережения установил в высокую производительность. В случае с квадрантом помогло.

Убрал галочки про отключение устройств для энергосбережения. Надеюсь, это решит проблему.

Нет - всё так же загорается и гаснет лампа на ThrottleBox и устройство пропадает из списка.

Edited by 72AG_Crusader

Share this post


Link to post
Share on other sites

А если в настройка плана электропитания ещё запретить usb отключать?

Share this post


Link to post
Share on other sites

А если в настройка плана электропитания ещё запретить usb отключать?

Не помогло

Share this post


Link to post
Share on other sites

Когда с сайтековским квадрантом возникла похожая проблема (через некоторое время простоя отключался, при этом гас светодиод на нём, что раздражало), поснимал галки экономии энергии в свойствах всех устройств, связанных с usb. Ну и режим энергосбережения установил в высокую производительность. В случае с квадрантом помогло.

О, а я то думаю. куда у меня квадрант стал отваливаться ) Спасибо большое за наводку.

Share this post


Link to post
Share on other sites

Повторю вопрос - версия прошивки какая?

Share this post


Link to post
Share on other sites

Hi,

 

The workaround I'm using to avoid the system connection/disconnection signals is to start the VKB Device Config software when Windows (8.1/10) starts.

That way your devices are always ON (no more annoying sound alerts).

 

 

(Google Translate)

 

Обойти я использую , чтобы избежать системных сигналов соединения / разъединения , чтобы начать VKB Device Config , когда ОС Windows ( 8.1 / 10 ) начинается .
Таким образом, ваши устройства не всегда на ( не более раздражает звуковые оповещения ) .

Edited by Bourrinopathe

Share this post


Link to post
Share on other sites

Не совсем по теме ВКБ, однако заметил, что у меня с рудом Warthog в "семёрке" такая проблема. Все технологии энергосбережения для USB отключены, РУС не отваливается, а вот с РУД такая история, слышен звук как будто устройство подключили, отключили. И ещё в этот момент в игре могут сработать некоторые кнопки самопроизвольно. Просто в качестве наблюдения мат. плата Asrock Z77 Extereme 4.

Share this post


Link to post
Share on other sites

Не совсем по теме ВКБ, однако заметил, что у меня с рудом Warthog в "семёрке" такая проблема. Все технологии энергосбережения для USB отключены, РУС не отваливается, а вот с РУД такая история, слышен звук как будто устройство подключили, отключили. И ещё в этот момент в игре могут сработать некоторые кнопки самопроизвольно. Просто в качестве наблюдения мат. плата Asrock Z77 Extereme 4.

здравия желаю парни,была и у меня проблема с кабаном так решил хаб удлинитель в надежное юзб и все окей

Share this post


Link to post
Share on other sites

Приветствую, ThrottleBox: руд Cougar в связке с трёхосными педалями на марсах, при обновлении на более новую прошивку отваливаются марсы, кнопки на руле некорректно работают  (дублируются) и идёт наложение кнопки на кнопку. Перепробовал в плоть до 1.96А(2). На  версии 1.80В связка руд+педали работает, планирую подключить через верхнюю коматоционную плату доп. плату +16 кнопок.

1-1_0.png

3-1.png

4-1.png

7.png

Share this post


Link to post
Share on other sites
Posted (edited)

Скачайте у Алекса. 

VKB Config 0.89.60
Throttle Box v.1.96.7

Ваша версия конфигуратора поддерживает 1.95.4 , а Вы уже 1.96 прошили.скорее всего и Мамба с ума сходит. 

Edited by =19fab=Zorik79
  • Upvote 1

Share this post


Link to post
Share on other sites

Конфигуратор менялся с учётом прошивки.

Для 1.96А конфигуратор использовал 0.89.90

 

Share this post


Link to post
Share on other sites
1 час назад, MaziLLa сказал:

Конфигуратор менялся с учётом прошивки.

Для 1.96А конфигуратор использовал 0.89.90

 

В шапке конфигуратора написано 1.95.4. 

Share this post


Link to post
Share on other sites

Пробовал и по разному, рабочая прошивка 1.80B, при обновлении прошивки (смене конфигуратора) и выставления параметров см. скин2 марсы отваливаются, кнопки дублируются и присутствует наложение кнопка на кнопку.

1.png

2.png

3.png

Share this post


Link to post
Share on other sites
Posted (edited)

 у меня был немного другой случай ( тоже с Тратл Бокс ).
Мне пришлось обнулять ТратлБокс, прошивать на дефолтную версию ( по-моему 1.58.9) и потом заного делать Upgrade прошивке.

(И еше мне прислось пул ап на 3-ю ось припаять, но ето другая история )
Давайте спросим @VictorUs @Alex_Oz, а то я шас наговорю лишнего

Edited by =19fab=Zorik79

Share this post


Link to post
Share on other sites

По наложению кнопок будем посмотреть, но надо собирать железку - поэтому быстро не будет.

 

Марсы скорее всего потому что от Геймтриксовского руля - не вытягивают по таймингам.

Share this post


Link to post
Share on other sites
Posted (edited)

del

 

 

Edited by Alex_Oz

Share this post


Link to post
Share on other sites
Posted (edited)

Сегодня поменяю на Марсы 4.0

 

Edited by MaziLLa

Share this post


Link to post
Share on other sites
Posted (edited)

Таки да, из всей матрицы опрос идет только одной линии и  произошло это достаточно давно.

При том что в Гладиаторе матрица работает.

Edited by Alex_Oz

Share this post


Link to post
Share on other sites
Posted (edited)

Произвёл замену марсов на 4.0, при обновлении прошивки идёт отвал марсов. Сброс в дефолт помогает оси настраиваются, но после того, как произвёл изменения (см. скин 2 выше) в закладках конфигуратора  Common, External  марсы отвалились.

Edited by MaziLLa

Share this post


Link to post
Share on other sites
Posted (edited)

Посмотрите v1_96_A(3)

 

Выше по настройкам - почему 2 регистра физических? Если так, то виртуальные надо сносить ниже -конфликт же показан.

Посмотрел по схеме - матрица кугара 3х4 (Row=3)

 

1869115011_CougarDSUB-15.gif.f8e1017a0fa1e436adfca699d1edab72.gif

Edited by Alex_Oz

Share this post


Link to post
Share on other sites

Прошивка 1.96А(3) заработала, благодарю Alex_Oz 👍💪.

Share this post


Link to post
Share on other sites

Пожалуйста.

Странно и показательно одновременно - что за несколько лет этого никто больше не обнаружил.

  • Thanks 1

Share this post


Link to post
Share on other sites

Помнится читал на ВКБешном форуме, что есть возможность замены штатного Кугаровского потенциометра (оси газа) на марс, но для этого нужно на печатной плате Кугара убрать один сдм-резистор. Нужна информация, хочу реализовать🤔

Share this post


Link to post
Share on other sites
Posted (edited)

Проще наверно заново отследить подключение по железке.

Речь скорее шла чтобы добавить резистор подтяжки - его удобно припаять к ногам разъема именно SMD. Можно на сам Марс ( между + и средним), 5-12 кOm

Edited by Alex_Oz
  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...