Jump to content
adi_das

проблема с РУД Gametrix ECS

Recommended Posts

 Подключил РУД Gametrix ECS (прошивка 1.32) : кнопки назначаются и работают, а вот с назначением оси на рычаги управления двигателями проблема. После назначения РУД в игре начинает дергаться и не реагирует на движение РУД Gametrix ECS. Не добавить тяги, не убавить... 


   Может кто знает причину и как ее устранить?


Share this post


Link to post
Share on other sites

Проблема обнаружилась: два устройства подключены были через один порт USB. Разнес РУД и РУС на разные порты и все стало ОК.

Share this post


Link to post
Share on other sites

Да, бывает такое на низкоскоростных USB. Обычно когда несколько низкоскоростных устройств подключены рядом.

Share this post


Link to post
Share on other sites

Была прошивка 1.27

Решил перепрошить до 1.35 и возникла проблема с ручкой газа

От себя не до конца отсчитывается

На себя примерно с половины хода отсчет в ноль

После калибровки в винде от себя отсчитывается до конца,а на себя смотри предыдущий пункт

винда 7х64

картинки прилагаю для наглядности

post-1066-0-44259200-1427053100_thumb.jpg

 

также вопрос как калибровать в даной проге

 

post-1066-0-90204700-1427053203_thumb.jpg

Share this post


Link to post
Share on other sites

вопрос почти решен скачиванием версии проги 0.7.2.9

последующей в ней калибровки и далее калибровки в винде

Share this post


Link to post
Share on other sites

вопрос почти решен скачиванием версии проги 0.7.2.9

последующей в ней калибровки и далее калибровки в винде

Ссылочку можно?

Share this post


Link to post
Share on other sites

вопрос почти решен скачиванием версии проги 0.7.2.9

последующей в ней калибровки и далее калибровки в винде

Тоже было подобное. Сразу с магазина перешился на 1.35, калибровал...

После прочтения этого поста: http://forum.il2sturmovik.ru/topic/947-defender-cobra-m5/page-26?do=findComment&comment=279725 решил поставить 1.33 и положение улучшилось, то есть в обе стороны практически до конца оси стали отрабатывать.

Мертвые зоны убирал совсем, но в итоге остановился на - по 10 с обоих сторон, оно не критично )

Share this post


Link to post
Share on other sites

уже сам нашёл:)

Edited by huligan

Share this post


Link to post
Share on other sites

скиньте линк на упоминание.

Share this post


Link to post
Share on other sites

я просто сначала забыл залогиниться,потом вспомнил и скачал:)

Share this post


Link to post
Share on other sites

Игра не видит регулятора тяги на РУДе,прошивка 1.35, помогите, кто решал подобное

Share this post


Link to post
Share on other sites

А вот на добавленные резисторы, которые припаяны к микроконтроллеру, можно фильтр назначить как-либо?

Share this post


Link to post
Share on other sites

А вот на добавленные резисторы, которые припаяны к микроконтроллеру, можно фильтр назначить как-либо?

Нет. 4 и 5 -я оси были примотаны к ECS изолентой, поэтому их нет в параметрах (и не будет) - и соответственно сконфигурировать их нельзя. :o:

  • Upvote 1

Share this post


Link to post
Share on other sites

Сконфигурировать нельзя, но можно также изолентой для этих двух осей одновременно прикрутить фильтрацию в прошивку. Поскольку оси не основные, и такое дело требуется для борьбы с шумом резисторов, то уровень фильтрации следует сделать ближе к максимальному.

Правда сейчас беда со временем - обещать ничего не буду, подумаю над этим.

Edited by Alex_Oz
  • Upvote 2

Share this post


Link to post
Share on other sites

Спасибо!

 

Забирайте, v1.39 :pioneer: 

Если там маловато по уровню - можно добавить  :)

Или наоборот.

Edited by Alex_Oz
  • Upvote 3

Share this post


Link to post
Share on other sites

Забирайте, v1.39 :pioneer: 

Если там маловато по уровню - можно добавить  :)

Или наоборот.

Класс, спасибо! 

Все работает как надо.

 

Единственное, 

2. конфигуратором сбросить параметры в дефолт

не нашел в конфигураторе. Или это какая-то последовательность действий?

Edited by myselfcontrol

Share this post


Link to post
Share on other sites

После записи строчки User=Developer в секцию [user] файла zconfig.ini (создается после первого запуска в папке конфигуратора), появится кнопка "Default" в Tools. После ее активации происходит сброс к заводским.

  • Upvote 1

Share this post


Link to post
Share on other sites

После записи строчки User=Developer в секцию [user] файла zconfig.ini (создается после первого запуска в папке конфигуратора), появится кнопка "Default" в Tools. После ее активации происходит сброс к заводским.

Cпасибо! 

Share this post


Link to post
Share on other sites

О!

филтры на доп оси!Зергут!Забрал! :biggrin:

Share this post


Link to post
Share on other sites

Подскажите вот по этому графику.

Руд Гаметрикс стал жить соей жизнью... немного показания ползут вперёд. Не сильно и не критично.

Это можно как то исправить не включая перфоратор и не используя крестовую кувалду?

 

(руки заточены под Zeva+)

 

3730bbbffd8b.jpg
Edited by =WAR=Serge-99

Share this post


Link to post
Share on other sites

не вижу уползания. или вы про небольшую дрожь?

Share this post


Link to post
Share on other sites

в центральном положении дёргается, но не во все стороны, а к увеличению и потом обратно в ту же позицию.

когда в ноль ставлю - ровно, и когда по-максимуму - тоже ровно.

 

Edited by =WAR=Serge-99

Share this post


Link to post
Share on other sites

не вижу проблемы. дергается на 64 единицы при 65 535 отсчетах. Это очень малое значение.

Share this post


Link to post
Share on other sites

Да я говорю, что не критично.

Просто такого не было и решил спросить.

Может кто скажет что. Типа откалибруй, переустанови прошивку, выдерни и вставь шнурок.

Понравилось про шнурок. Самое оказалось простое. Шнурок выдернул - вставил. Тоже самое.... )

 

В общем не критично - значит не критично.

 

Вчера в одной игре выставил на синенькую полосочку, чтобы прилететь на определённой скорости к объекту, а оно - РАЗ и проскочил.... Скорость увеличилась....

Так сидел с кружкой кофе, а теперь рука занята... (

Держу - контролирую.. )

 

Теперь без кофе и бутербродов )

Edited by =WAR=Serge-99

Share this post


Link to post
Share on other sites

65 единиц - это где-то два отсчета при разрешении оси в 2048 отсчетов - по идеи не должно даже ощущаться...

Share this post


Link to post
Share on other sites

Да там ползунок в синей зоне в одной игре и я почуял, что он ползёт и перепугался....

Думал, что поломалось чего. )

Спасибо.

 

Я понял, что если ломается, то ползёт непредсказуемо, а это... пустяк значит.... Перестраховался значит.

Share this post


Link to post
Share on other sites

Отказалась работать ось Х РУДа на новой системе вин 10. Хотя крутилки работали и прошивка перепрошивалась поначалу, потом перестала. Под конец РУД перестал определяться в конфигураторе %) Проверил на старой системе, РУД работает как надо. Полез в настройки винды "синийзуб и другие устройства", оказалось вин 10-ка приостановила настройку устройства из-за лимитного подключения интернет! Жёваный крот! После установки галочки "скачивание через лимитное подключение" заработало.  А я уже было начал подыскивать новый РУД  )

Share this post


Link to post
Share on other sites

А при чёт тут РУД и интернет???:o:

Как может работоспособность джойстика зависеть от интернет-подключения?

  • Upvote 1

Share this post


Link to post
Share on other sites
В 06.01.2019 в 02:45, huligan сказал:

А при чёт тут РУД и интернет???:o:

Как может работоспособность джойстика зависеть от интернет-подключения?

Это надо у мелкомягких спросить, "приостановила настройку устройства из-за лимитного подключения" это почти цитата винды. Видимо, 10ка после установки галочки полезла в сеть за драйверами или сертификатами и сразу на все устройства изменила статус. Допускаю, что могло совпасть с какими-то моими действиями ещё, ведь настройка всех органов управления, происходит через хитро закрученную жопу.

  • Confused 1

Share this post


Link to post
Share on other sites

Имеется 2 контроллера Gametrix ECS. Раньше были прошиты на 1.35, в диспетчере устройств, в устройствах и в VKB_JoyTester оба отображались, как разные устройства, с разным VID-PID, конфигуратор VKBDevCfg-C создавал 2 разных файла реестра для этих устройств.

Решил прошить до 1.39-2. Теперь у обоих устройств одинаковый  VID-PID, в диспетчере устройств все так же видно 2 устройства, в устройствах и в VKB_JoyTester оба отображаются, но с одинаковым  VID-PID. Конфигуратор VKBDevCfg-C создает 1 файла реестра для этих устройств. 

 

Прошивались по отдельности. Один отключался, другой прошивался. Еще было удаление устройств из системы, но вроде бы это было уже после того, как они стали одинаковыми. Были и сбросы к заводским настройкам, возврат к 1.35, ничего не поменялось.

 

Как им сделать разный  VID-PID и почему так получилось. Ярко горящий диод при включении никак не исправить? Ради него и прошивал, думал это поправлено.

Edited by JGr8_Leopard

Share this post


Link to post
Share on other sites

В конфигураторе в Global есть окошко SN 0000 - задай одному номер на 1 больше и сохрани. Это работает, если в системе больше одного BB связанных по шине. Думаю, и с ECS прокатит. По Led - а в [User] строка User=Developer есть? Файл zconfig.ini в папке конфигуратора.

Share this post


Link to post
Share on other sites
1 час назад, -DED-Ron сказал:

В конфигураторе в Global есть окошко SN 0000 - задай одному номер на 1 больше и сохрани. Это работает, если в системе больше одного BB связанных по шине. Думаю, и с ECS прокатит. По Led - а в [User] строка User=Developer есть? Файл zconfig.ini в папке конфигуратора.

Нет окошка SN. и они не связаны по шине. Каждый в свой юсб втыкается.

Строка User=Developer есть.

Share this post


Link to post
Share on other sites

PID для VKB Trottle неизменен с давних времен, но естественно он отличается от родного ECS. Свободным он никогда не был и не будет.

Оригинальную прошивку можно скачать с сайта Gametrix, там же утилита калибровки.

 

 

По серийнику надо смотреть, ничего пока обещать не могу.

По светодиоду - надо найти более ранний конфигуратор, где еще были настройки SysLedMode - там можно выключить.

 

 

 

 

Edited by Alex_Oz

Share this post


Link to post
Share on other sites
57 минут назад, Alex_Oz сказал:

По светодиоду - надо найти более ранний конфигуратор, где еще были настройки SysLedMode - там можно выключить.

 

 

 

 

Конфигуратор  0.77.2.3.

Прошивка Gametrix ECS.Версия 1.35.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...