Jump to content
mega_mozg_13

MMJOY2 (бесплатная прошивка и софт для самодельного контроллера джойстика)

Recommended Posts

Я ставил два разных, от разных джойстиков. Результат одинаковый. Может неправильно подсоединяю? Если крутилка на себя и контакты слева, то сверху вниз - питание, сигнал, минус. Вроде так на схеме видел.

Edited by JG.SS_Habicht

Share this post


Link to post
Share on other sites

Как именно Vcc +5  и GND подключены к потенциометру не имеет значения (для этого существует опция в конфигураторе - инверсия). Средний всегда сигнал.

А вот, что ставили два разных и от разных джойстиков  это уже интересно.

Какие номиналы подключаемых потенциометров?

С номиналом 10 kOm нет никаких проблем. 

Edited by Vumpel18
исправление

Share this post


Link to post
Share on other sites

Один от "Top Gun Aft.", а второй от древнего китайского какого-то. Но думаю, в пределах 100кОм.

 

Померил, один 65, второй 100 

Действительно, может нужен именно 10кОм.

Edited by JG.SS_Habicht

Share this post


Link to post
Share on other sites

Стоит попробовать 10кОм.

  • Thanks 1

Share this post


Link to post
Share on other sites

Ты не ответил сырое значение меняеться? И сделай скин конфигуратора, а то лечим даже не по фотографии. А лучше видио. П.с. есть вероятность что резюки износились.

  • Thanks 1

Share this post


Link to post
Share on other sites

Подскажите пожалуйста, где какие выводы на этом резисторе?

 

Скрытый текст

DOC000280764.jpg

 

Подключаю к ардуинке: реакции ноль, хотя при измерении сопротивления резистор рабочий.

Edited by =CCCP2=StrangerKZ

Share this post


Link to post
Share on other sites

Ну там же прямо на резисторе нарисовано :) Крайние на +5в и GND, средний на АНАЛОГОВЫЙ вход  ардуинки , аналоговые это F4-F7,D4,D7,B4,B5,B6

Share this post


Link to post
Share on other sites
33 минуты назад, Magenta сказал:

Ну там же прямо на резисторе нарисовано :) Крайние на +5в и GND, средний на АНАЛОГОВЫЙ вход  ардуинки , аналоговые это F4-F7,D4,D7,B4,B5,B6

 

Проверки ради. Не работает. В ардуинке висит одно значение, оно не меняется. Подключил к резистору светодиод, резистор рабочий, регулировка яркости диода происходит. Ардуина тоже работает, подключал датчик Холла. Черт его знает, что ещё надо.:biggrin:

Share this post


Link to post
Share on other sites
1 час назад, =CCCP2=StrangerKZ сказал:

Подскажите пожалуйста, где какие выводы на этом резисторе?

 

  Показать содержимое

DOC000280764.jpg

 

Подключаю к ардуинке: реакции ноль, хотя при измерении сопротивления резистор рабочий.

Это обычный резистор? Бывают подобные с ШИМ.

Share this post


Link to post
Share on other sites

К какому порту цепляете на ардуино ? И покажите экран сетапа где цепляете ...

Share this post


Link to post
Share on other sites
1 час назад, semenovkr сказал:

Это обычный резистор? Бывают подобные с ШИМ.

 

Обычный. В прошлом году работал.

 

1 час назад, Magenta сказал:

К какому порту цепляете на ардуино ? И покажите экран сетапа где цепляете ...

 

Цеплял к В5, я уже все раскидал, смысл мучить это дело, проще на Тле посадить. Мне для руля надо было, резюк многооборотный, хотел на первое время присобачить. Увы.;)

Share this post


Link to post
Share on other sites
45 минут назад, =CCCP2=StrangerKZ сказал:

резюк многооборотный

Может в этом и проблема? Попробуй обычный резюк с линенйной характеристикой. Он потому и много оборотный что в сравнении с обычным резюком, для изменения  значения(к  примеру, все цифры условны) на 1 кОм обычному резюку надо сделать угол поворота 20 градусов, а многооборотному полных полтора оборота, а то и больше.. Может быть изменение сопротивления настолько мало для хода оси, что ардуина не понимает что ось работает.

Edited by =19fab=Alator

Share this post


Link to post
Share on other sites

Ни свет, ни заря, не емши, не ср..ши, побежал сегодня, стуча каблучками, по сырой, от утренней расы, мостовой в лавку радиодеталей. Спешу всех, принявших живое участие в моей затыке с резюками, невероятно обрадовать - дело было все-таки в номинале. Видимо, ардуинка  корректно работает только с 10кОм-никами. 

Share this post


Link to post
Share on other sites

Ура ааа аа а !

Скрытый текст

Старые резюки в топку.

 

Share this post


Link to post
Share on other sites

Народ, эт снова я. Принялся подключать кнопки по схме из поста Мусульманина bandicam 2015-05-31 00-16-48-843.jpg

и при нажатии на кнопку (на любую из трех подключенных) в конфиге срабатывают сразу три штуки. Что я е так сделал? 

 

333.jpg

Share this post


Link to post
Share on other sites
13 минут назад, JG.SS_Habicht сказал:

Народ, эт снова я. Принялся подключать кнопки по схме из поста Мусульманина 

и при нажатии на кнопку (на любую из трех подключенных) в конфиге срабатывают сразу три штуки. Что я е так сделал? 

 

333.jpg

Ну конечно будут нажиматься сразу три. Ты ж в колонках везде поставил порт D3

Edited by =FA=CATFISH

Share this post


Link to post
Share on other sites

Ну да. так колонка-то  одна, как и на схеме. Или я чего-то не допонимаю? Я подключил к одной колонке и к трем рядам 3 кнопки.

Edited by JG.SS_Habicht

Share this post


Link to post
Share on other sites
18 часов назад, JG.SS_Habicht сказал:

Ни свет, ни заря, не емши, не ср..ши, побежал сегодня, стуча каблучками, по сырой, от утренней расы, мостовой в лавку радиодеталей. Спешу всех, принявших живое участие в моей затыке с резюками, невероятно обрадовать - дело было все-таки в номинале. Видимо, ардуинка  корректно работает только с 10кОм-никами. 

 

Скореевсего не номинал а изношенность старых резисторов, они на родных джоях нормально работали?  Но ладно не суть важна, если проблему решил. 

Share this post


Link to post
Share on other sites
В 25.09.2018 в 13:17, =LwS=DAZZ сказал:

Вопрос назрел, кто конектил вирпиловскую ручку к ммджой2? Как она подключалась, без бубнов? Сколько общее количество кнопок вышло?

Купил на taobao "ChinaMMJoy" - 2шт.

Оказались с предустановленной прошивкой от MegaMozg [v20160818], НО без bootloader.

Попробовал установить bootloader, в результате одну плату привел в норму и установил [v20161101].

Другая ведет себя странно. Видна в Диспетчере Задач как Arduino Leonardo на COM8, но после нажатия Reset, Диспетчер Задач моргает, и снова показывает этот порт.

Т.е. не переходит в bootloader.

Варианты восстановления bootloader из Инета не помогают. Пробовал Arduino, FLIP. Собрал AVRISP MkII и через дудку пробовал bootloader залить. Не видят или выдают ошибку.

Кто нибудь сталкивался?

021.png

p1.png

p2.png

Share this post


Link to post
Share on other sites
16 часов назад, Arachna сказал:

Купил на taobao "ChinaMMJoy" - 2шт.

Оказались с предустановленной прошивкой от MegaMozg [v20160818], НО без bootloader.

Попробовал установить bootloader, в результате одну плату привел в норму и установил [v20161101].

Другая ведет себя странно. Видна в Диспетчере Задач как Arduino Leonardo на COM8, но после нажатия Reset, Диспетчер Задач моргает, и снова показывает этот порт.

Т.е. не переходит в bootloader.

Варианты восстановления bootloader из Инета не помогают. Пробовал Arduino, FLIP. Собрал AVRISP MkII и через дудку пробовал bootloader залить. Не видят или выдают ошибку.

Кто нибудь сталкивался?

021.png

p1.png

p2.png

А по чем это чудо?

Share this post


Link to post
Share on other sites

ChinaMMJOY c с комплектом кабелей и кабелем USB - 957

HC165x3  с комплектом кабелей - 215

TLE5010  с кабелеv - 215

это с доставкой до Благовещенска

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Только что, Arachna сказал:

ChinaMMJOY c с комплектом кабелей и кабелем USB - 957

HC165x3  с комплектом кабелей - 215

TLE5010  с кабелеv - 215

А можно ссылки,если не трудно.Спасибо.

Share this post


Link to post
Share on other sites

Месяц назад тож с бубном прыгал вокруг ардуины, джой РУС был рабочий, решил перепрошить, и после, тоже значения стали не на полную отображаться (хотя ТЛЕ а не резюки), но я так бил бубном и паяльником что ухайдохал шкер питания. хотя докапался до истины, надо было просто виндовским калибратором откалибровать диапазоны.  На руде стоят резюки 100к и норм работают.

Share this post


Link to post
Share on other sites

Что за ошибка?error.jpg.70441343f651fe7b65310fad7ea31d06.jpg

Share this post


Link to post
Share on other sites

Вы пытаетесь запустить второй конфигуратор, когда первый уже запущен и наверное свернут с рабочего стола.

Повнимательнее и такой ошибки не будет.

Edited by Vumpel18
исправление

Share this post


Link to post
Share on other sites

Разные джойстики скрывают в своих недрах разные раз.емы подключения. Нарисовал универсальную монтажную панельку под шаг от 1 до 2.54. Может есть еще идеи для  реализации?

 

IMG_20181024_142330.jpg

Share this post


Link to post
Share on other sites

Не получится поменять версию из оболочки MMJoy2, только с помощью программатора.

А так будет работать на встроенной [v20160818] версии. Если не важны изменения, сделанные в [v20161101] , то можно и так жить.

[v20161101] нет нового ключевого ничего. народ просит дать возможность повторно использовать источники осей на разные оси."

Share this post


Link to post
Share on other sites
5 часов назад, Arachna сказал:

[v20161101] нет нового ключевого ничего. народ просит дать возможность повторно использовать источники осей на разные оси."

Можно подробнее: что это и какой профит?

Share this post


Link to post
Share on other sites
11 часов назад, Vumpel18 сказал:

Вы пытаетесь запустить второй конфигуратор, когда первый уже запущен

Никак нет, Товарищ!

У меня РУД и педали на ММДжое. Педальки при считывании из контроллера в конце выдают такую ошибку. Но при этом работают.

Share this post


Link to post
Share on other sites
9 часов назад, SSV сказал:

Никак нет, Товарищ!

У меня РУД и педали на ММДжое. Педальки при считывании из контроллера в конце выдают такую ошибку. Но при этом работают.

Было такое, вылечил сменой прошивки.

 

Share this post


Link to post
Share on other sites
13 часов назад, Altair24 сказал:

Было такое, вылечил сменой прошивки.

Оказалось, что конфигурация ему не нравилась. Прошивку не менял, просто выполнил сброс и заново настроил. Ошибка исчезла.

  • Upvote 1

Share this post


Link to post
Share on other sites

Человеки, салют! Почему винда в игровых устройствах не видит кнопки во второй назначенной колонке (ардуино микро), хотя в конфигураторе они работают?

 

setupkey.jpg

Edited by JG.SS_Habicht

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...