Перейти к содержимому

Рекомендованные сообщения

Странно, но у меня почему-то не хочет устанавливатся SST програмуля. Установил последние драйвоа с сайта для x52, скачал последнюю версию SST x64, вроде устанавливается, но найти ее не могу.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

не надо качать последнее, оно все глючное

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Решил проблему )

Если кому-то будет нужно из владельцев Saitek

Описание проблемы: Ставим драйвера с сайта Saitek на Windows. После этого ставим SST. SST устанавливается, появляются Magic Bus устройства, но ни редактора профиля, ни самого профайлера нет. Ни в пуске, ни в програмных файлах.
Причина проблеммы в том что установщик не может определить язык системы.Требуется установить вручную.
Нужно зайти в папку Windows\Temp\ и найти там папку созданную установщиком (что типа Cyborg_RAT_9_Gaming_Mouse_SD7_64_Software\00000010) и найти там установочный файл с software_loc_9.msi это и будет установка для русской версии Windows. Если не можете найти в ручную файл, то можно воспользоваться поисковиком Windows (Ctrl+F).

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

 

Ставим драйвера с сайта Saitek на Windows.

Не надо с сайта, можно с ФТП-шника.

 

ftp://ftp.saitek.com/pub/software/xpvista/
 

Для Х-52 Pro:

Драйвер - Saitek_X52Pro_Flight_Controller_SD6_16_64_Drivers. exe
Редактор SST - SST_SD6_16_64_Software.exe
или же с аналогичными именами, но под 32-битную систему, где вместо "64" указано "32".

 

Для Х-52:

Драйвер - Saitek_X52_Flight_Controller_SD6_15_64_Drivers.exe

Редактор SSt - тот же самый.

 

При установке именно этих драверов и именно этого редактора для Х-52/Х52Pro не нужны будут "танцы с бубном", которые выше описаны.

 

В той же директории - "\xpvista" есть драйвера и под все остальнрые разновидности девайсов.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

 

Потому я просто отказался от комбинаций с шифтом.

В таком случае нужно будет перелапачивать все настройки в симе, а это уже гемморой. Как сказал выше, свою проблему решил через макросы (в некоторых командах пришлось выставлять задержку удержания кнопок до 10 сек.) и плюс отключением "оверлея" в Стиме.

 

 

 

что он кнопку Shift кодирует именно как Shift, а не LShift,

Давно это было, сейчас не скажу в какой именно версии драверов была такая трабла.

В этой теме - http://forum.il2sturmovik.ru/topic/2008-nastrojki-upravleniya/?do=findComment&comment=215963 отписал, с какими версиями драйверов все Шифты интерпретируются по отдельности, как LShift/RShift.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Что-то я не пойму....

Настроил профайл для x52. Все работает, все устраивает. И только одна операция идет криво...

Настроил на кнопку i (на руде) выпускать и убирать воздушный тормоз (Ralt+B). Тормоз выпускается и убирается, но при этом сбрасывается по одной внешней бомбе при каждом клике на кнопку. Т.е. вместе с выпуском тормоза (или убиранием) сбрасывается одна бомба с внешней подвески.

Пробовал биндить эту операцию на другую кнопку - результат тот же.

Натройки клавиатуры по умолчанию:

Сброс бомб - B

Выпуск/убирание воздушного тормоза - Ralt+B

Помогите советом.

 

P.S. Кстати, подобная проблема у меня и с выпуском/убиранием закрылок (только на Пе-2). Выпускаются нормально, убиратся не хотят. Как зацепка, в обоих операциях присутствует кнопка F. Может в этом затык?

Изменено пользователем =SR=SokRus

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Скорей всего. У меня было, что комбинации профайлера отрабатывали не четко. Попробуй в профайлере изменить порядок "нажатия/отпускания" кнопок. Т.е. сначала нажимается Алт, потом В, потом В отпускается, потом Алт отпускается. И с закрылками так же. Я сам это не пробовал, но по логике должно помочь

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Скорей всего. У меня было, что комбинации профайлера отрабатывали не четко. Попробуй в профайлере изменить порядок "нажатия/отпускания" кнопок. Т.е. сначала нажимается Алт, потом В, потом В отпускается, потом Алт отпускается. И с закрылками так же. Я сам это не пробовал, но по логике должно помочь

В профайле есть два режима. Назначение кнопок (кнопки на белом фоне) и макрос (кнопки на сером фоне). В чем разница? Попробовал макрос забиндить из двух кнопок, воздушный тормоз не выпускается, но, правда, и бомбы не сбрасываются.

Вообще, при назначении кнопок в профайле, важно держать нажатым alt (к примеру), или учитывается только порядок нажатия?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Макросы я один раз только смотрел, подробностей не помню. вообще порядок нажатия и отпускания важен. кнопка должна нажиматься при удерживаемом модификаторе. Отпускаться тоже при удерживаемом.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Давно это было, сейчас не скажу в какой именно версии драверов была такая трабла.

В этой теме - http://forum.il2sturmovik.ru/topic/2008-nastrojki-upravleniya/?do=findComment&comment=215963 отписал, с какими версиями драйверов все Шифты интерпретируются по отдельности, как LShift/RShift.

Понятно. Я этого не знал, т.к. я наверное года 3 назад подобрал рабочую конфигурацию дров и больше ей не заморачивался. А сейчас, с полным уходом от Х52 мне проблема не актуальна...

Пишу потому, что мой опыт может тоже кому-то пригодиться...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Странно, но так и не получилось исправить эту проблему...

Нашел выход в следующем:

В профайлере нахожу на РУСе кнопку Т1, кликаю на треугольник и выбираю пункт "новые дополнительные команды". В появившемя окошке даю название и в первом поле кликаю Ralt и через долю секунды B. Лишние появившиеся кнопки удаляю. Вуаля...

Тоже самое сделал и на уборку закрылок.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В конечном итоге, все кнопки пришлось настраивать в самой игре ( Хрень какая-то.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В конечном итоге, все кнопки пришлось настраивать в самой игре ( Хрень какая-то.

Так я же специально про это выше и писал, что в БзС приходится писать макросы, вместо стандартного забивания комбинаций. Ну это не страшно.

Нужно использовать два вида "расширенных команд": с макросом и без макроса.

 

С макросом:

x4706101m6r3b054a5.png

Забивается для тумблеров переключения. Установил одинаковый интервал для всей последовательности в 0,030. Смело можно и в 0,025.

 

Без макроса:

k4v0u101t6a3t0v4z5.png

Интервал между симуляцией "нажатия" обеих кнопок и их "отпускания" равен 10 секундам.

 

В чём смысл.

Макрос выполняется до конца, даже если вы отпустили кнопки раньше того промежутка времени, который назначен в макросе. Т.е. нажали, отпустили кнопки, но вся последовательность нажимания/отпускания кнопок всё равно продолжит выполняться.

 

Расширенная команда, без установленной галочки "макрос".

Эта последовательность команд будет выполняться только до тех пор, пока вы удерживаете в нажатом состоянии соответствующую кнопку/шляпку устройства. Как только отпускаете её, то прекращается выполнение команды. В данном случае это актуально для выпуска закрылок, перевода рычагов ВОДО и МАСЛОРАДИАТОРА и т.п.

  • Поддерживаю! 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот некоторые операции я так и сделал. Без макроса.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Всем добрый день !
Не могу нормально настроить сей девайс. Хочется задействовать вот этот "ползунок" (spoiler) на приближение и удаление взгляда. Сим не видит eгo в настройках. Может кто  с этой проблемой уже сталкивался ?

 

 

x52.jpg

 

Изменено пользователем Duessell

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Всем добрый день !

Не могу нормально настроить сей девайс. Хочется задействовать вот этот "ползунок" (spoiler) на приближение и удаление взгляда. Сим не видит eгo в настройках. Может кто  с этой проблемой уже сталкивался ?

 

 

x52.jpg

 

На приближение и удаление? Или все же на ЗУМ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

На приближение и удаление? Или все же на ЗУМ?

На зум конечно ! Перепутал немного :(

Приходиться или колесиком на мышки приближать или колесиком на РУДе. С ползунком было бы удобнее и быстрее

 

 

P.S Просто под рукой сейчас нет сима

Изменено пользователем Duessell

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

На зум конечно ! Перепутал немного :(

Приходиться или колесиком на мышки приближать или колесиком на РУДе. С ползунком было бы удобнее и быстрее

 

 

P.S Просто под рукой сейчас нет сима

Там самый первый пункт в настройках вида из кабины должен садиться на ось. Попробуй его.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Там самый первый пункт в настройках вида из кабины должен садиться на ось. Попробуй его.

Да проблем в том, что сим этот ползунок вообше не видит.... Эти танцы с бубном уже второй день продолжаются. Беда короче :(

После работы пройду домой и попробую дрова переустановить на джойстик.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Да проблем в том, что сим этот ползунок вообше не видит.... Эти танцы с бубном уже второй день продолжаются. Беда короче :(

После работы пройду домой и попробую дрова переустановить на джойстик.

Может выплыть такая особенность: Когда настраиваешь его в симе - надо его поставить в центр, потом полностью до отказа в + и потом полностью до отказа в -.

Еще вариант - руками в конфиге прописать. У меня было такое - на педалях не виделись тормозные оси. Прописал в ручную - заработали и стали видеться.

Если не забуду - когда дома буду - подключу РУД и скажу букву оси ползунка. Но это будет поздно вечером...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Может выплыть такая особенность: Когда настраиваешь его в симе - надо его поставить в центр, потом полностью до отказа в + и потом полностью до отказа в -.

Еще вариант - руками в конфиге прописать. У меня было такое - на педалях не виделись тормозные оси. Прописал в ручную - заработали и стали видеться.

Если не забуду - когда дома буду - подключу РУД и скажу букву оси ползунка. Но это будет поздно вечером...

 

Спасибо за совет ! Буду пробовать когда домой приеду.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вобщем слайдер опознается игрой как joy№_axis_p

 

Если он вдруг не опознается - значит не доводишь его до крайних положений оси. Обязательно доводи до упора с небольшим нажимом...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Наконец то  добрался до компа ! Спасибо за совет. Все получилось :popcorm:

Изменено пользователем Duessell

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здравствуйте. Скажите получилось ли у кого настроить переставной стабилизатор на джой?  К примеру на хатку? Пользую Х-52 про, назначил переставной стабилизатор на вторую хатку, она прописалась, но в полете от хатки управление не срабатывает, приходится перекладывать чезе дефолтную комбинацию клавиш.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здравствуйте. Скажите получилось ли у кого настроить переставной стабилизатор на джой?  К примеру на хатку?

На крутилку РУДа под большим пальцем стоит уже давно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здравствуйте. Скажите получилось ли у кого настроить переставной стабилизатор на джой?  К примеру на хатку? Пользую Х-52 про, назначил переставной стабилизатор на вторую хатку, она прописалась, но в полете от хатки управление не срабатывает, приходится перекладывать чезе дефолтную комбинацию клавиш.

Работает и на хатках и на крутилках (на мессе). На Фоке - на хатке.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Настроил в программе на  MOD2 кнопку на водорадиатор, но игра ее не распознает.  При переключении в MOD2 на джойстике, кнопка распознается как в MOD1.

Я уже и дрова и программу переустанавливал.... Помогите советом битте.

 

 

unbenanntbkv4aqw0ey.png

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Настроил в программе на  MOD2 кнопку на водорадиатор, но игра ее не распознает.  При переключении в MOD2 на джойстике, кнопка распознается как в MOD1.

Я уже и дрова и программу переустанавливал.... Помогите советом битте.

 

 

unbenanntbkv4aqw0ey.png

 

Подробней плиз. Дай полный скриншот окна, где видно что и как назначено... И как реагирует игра опиши или скрин с настроек в игре...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Добрался до компа и сделал 2 скриншота. В первом назначены кнопки на Т1 и Т2 в MOD1 на переключение шага винта и на MOD2 радиатором.

На втором скрине настройки из самой игры.

 

 

 

s52dhp8641m9q.png
 

2e0137njxg4.png

x5215zjwu6agqe.png

 

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

имхо, ты назначаешь как-то не правильно. Грубо говоря, я бы назначил так: В MOD1 поставил бы комбинации RSift+Equl и RShift+Minus. А в MOD2 RCtrl+Equl и RCtrl+Minus .  В игре - первую колонку оставил в соответствующих строках бы как есть. Во второй - кнопки джоя убил, чтоб не мешали. И все должно работать

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо за совет ! Все сделал как Вы написали, но изменений нет :(  При переключении в MOD1/MOD2 назначение клавиш отображаются на сайтековском дисплее, а в игре ничего не происходит.

Есть еще какие нибудь мыли по этому поводу ?

 

Можете свой конфиг выложить ? :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо за совет ! Все сделал как Вы написали, но изменений нет :(  При переключении в MOD1/MOD2 назначение клавиш отображаются на сайтековском дисплее, а в игре ничего не происходит.

Есть еще какие нибудь мыли по этому поводу ?

 

Можете свой конфиг выложить ? :)

Я сейчас на Х55 без профайлера. Если будет время посмотреть - попробую смоделировать ситуацию подключив Х52, но не обещаю, что 100% сделаю...

  • Поддерживаю! 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

начал осваивать SST и столкнулся со следующей проблемой

некоторые забинденые через shift команды работают странно, а именно - уборка закрылок - надпись на экране горит, а уборка не происходит. если забиндить клавиши в игре напрямую то все работает.

через некоторое время (около 2-3х минут) игра перестает реагировать на все команды клавиш настроенных через SST. Но настроенные напрямую в игре (кнопки и оси) работают нормально. 

выгрузка и подгрузка профиля не выходя из игры не к чему не приводит.

при выходе из игры она остается висеть в диспетчере задач, пропадает сеть.

подключено через USB2.0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

начал осваивать SST и столкнулся со следующей проблемой

некоторые забинденые через shift команды работают странно, а именно - уборка закрылок - надпись на экране горит, а уборка не происходит. если забиндить клавиши в игре напрямую то все работает.

через некоторое время (около 2-3х минут) игра перестает реагировать на все команды клавиш настроенных через SST. Но настроенные напрямую в игре (кнопки и оси) работают нормально. 

выгрузка и подгрузка профиля не выходя из игры не к чему не приводит.

при выходе из игры она остается висеть в диспетчере задач, пропадает сеть.

подключено через USB2.0

 

Ну теперь я рад, что я не один такой ! У меня вообще клавиша shift в SST не работает ! Короче засада с этим джоем и с игрой.

Как я уже тут писал,с другими играми проблем нет !

Изменено пользователем Duessell

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Может кривой SST с дровами? Откатить на предыдущую версию? У меня оно работало, но я SST года 2-3 назад ставил. Была единственная проблема с обработкой кнопки Shift, т.к. срабатывала она как Shift  а не как LSift... 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Всем привет. Вот и у меня та же проблема. Даже с дуру переустановил игру и дрова, потом пошла переустановка SST и всего остального. Но проблема так и осталась. Уткнулся башкой в стену и все.  :wacko:

Дальнейшие движения нароооооод ???? подскажите.

Или не заморачиватся дальше?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Добро пожаловать в клуб ! Я тоже уже все переустановил, а проблема все еще осталась не решенной. Мне просто обидно, что в таком хорошем симуляторе и такой джой просто палка с тремя кнопками :(

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вы напишите какой версии дрова и SST. При проверке отрабатывает LSift или только как Sift, не левый?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас

×